Follow me!: Follow @EricTheCoder_
Here is my cheat sheet I created along my learning journey. If you have any recommendations (addition/subtract...
For further actions, you may consider blocking this person and/or reporting abuse
More of a style thing, but for booleans I try to give them a verb name like:
which I’ve found makes my code read more semantically when the variables are used in conditional statements and loops
Oh come on, where is PHP8 features?
Good point. Will add those later today.
You seem to introduce a naming convention of camel case for var names, then immediately contradict it with
$isActive
?Good point :-)
Pretty good work, I am not sure, if it's only me, I must have used "while and do-while loop" no more than 2-3 times in the last 4 years
Nice list. Note: In at least 2 cases you use
__construc
where it should be__construct
Good catch. Corrected.
I need to benchmark it again, but ++$i is a micro optimizion you can use on your for loops. IIRC, do..while is another micro optimization you replace your while loops with, if you can guarantee at least one iteration.
That is great! I recently wrote a similar PHP guide here.
Wow this is great. Weldone
Very very useful and concise. Do you have it as a 1 or 2 pages PDF?