So I was implementing a forEach
method and asked my co-worker, "is there a name for a for-loop that iterates backwards? Something like:"
for (let i = myObj.length - 1; i >= 0; i--) { ... }
Of course, there wasn't one. So I set out to create one.
Meet rofEach
and the rof loop
. It's not only the word "for" backwards, it also means "Reverse Order For".
You're welcome, world. 🎤⬇️
Top comments (2)
Mike, this is awesome and hilarious.
Nomenclature. A burden, lightened somewhat. Thank you.